Current-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: My first look at updated "native" Xorg

The first machine I tried it on was equipped with some flavor of Radeon
graphics card (Sapphire X1500 or something like that):

radeon0 at pci1 dev 0 function 0: ATI Technologies product 7183 (rev. 0x00)
ATI Technologies product 71a3 (miscellaneous display) at pci1 dev 0 function 1 not configured
kern info: [drm] initializing kernel modesetting (RV515 0x1002:0x7183 0x174B:0x3
kern info: [drm] register mmio base: 0xfeaf0000
kern info: [drm] register mmio size: 65536
kern info: ATOM BIOS: X1550
kern info: [drm] Generation 2 PCI interface, using max accessible memory
radeon0: info: VRAM: 256M 0x0000000000000000 - 0x000000000FFFFFFF (256M used)
radeon0: info: GTT: 512M 0x0000000010000000 - 0x000000002FFFFFFF
kern info: [drm] Detected VRAM RAM=100M, BAR=256M
kern info: [drm] RAM width 128bits DDR
Zone  kernel: Available graphics memory: 901380 kiB
kern info: [drm] radeon: 256M of VRAM memory ready
kern info: [drm] radeon: 512M of GTT memory ready.
kern info: [drm] GART: num cpu pages 131072, num gpu pages 131072
kern info: [drm] radeon: 1 quad pipes, 1 z pipes initialized.
kern info: [drm] PCIE GART of 512M enabled (table at 0x0000000000040000).
radeon0: info: WB enabled
radeon0: info: fence driver on ring 0 use gpu addr 0x0000000010000000 and cpu addr 0x0xfffffaf6dc472000
kern info: [drm] Supports vblank timestamp caching Rev 2 (21.10.2013).
kern info: [drm] Driver supports precise vblank timestamp query.
radeon0: info: radeon: MSI limited to 32-bit
radeon0: interrupting at ioapic0 pin 18 (radeon0)
kern info: [drm] radeon: irq initialized.
kern info: [drm] Loading R500 Microcode
kern info: [drm] radeon: ring at 0x0000000010001000
kern info: [drm] ring test succeeded in 6 usecs
kern info: [drm] ib test succeeded in 0 usecs
kern info: [drm] Radeon Display Connectors
kern info: [drm] Connector 0:
kern info: [drm]   VGA-1
kern info: [drm]   DDC: 0x7e40 0x7e40 0x7e44 0x7e44 0x7e48 0x7e48 0x7e4c 0x7e4c
kern info: [drm]   Encoders:
kern info: [drm]     CRT1: INTERNAL_KLDSCP_DAC1
kern info: [drm] Connector 1:
kern info: [drm]   SVIDEO-1
kern info: [drm]   Encoders:
kern info: [drm]     TV1: INTERNAL_KLDSCP_DAC2
kern info: [drm] Connector 2:
kern info: [drm]   DVI-I-1
kern info: [drm]   HPD2
kern info: [drm]   DDC: 0x7e50 0x7e50 0x7e54 0x7e54 0x7e58 0x7e58 0x7e5c 0x7e5c
kern info: [drm]   Encoders:
kern info: [drm]     CRT2: INTERNAL_KLDSCP_DAC2
kern info: [drm]     DFP3: INTERNAL_LVTM1
radeondrmkmsfb0 at radeon0
radeondrmkmsfb0: framebuffer at 0xffffa4005b255000, size 1024x768, depth 32, stride 4096
wsdisplay0 at radeondrmkmsfb0 kbdmux 1: console (default, vt100 emulation), using wskbd0
wsmux1: connecting to wsdisplay0

Other than the glitches in 'xdm's login widget, everything seemed to
work fine--at least as far as my usual graphical environment (fvwm) was

The second machine I tried has intel graphics:

i915drmkms0 at pci0 dev 2 function 0: Intel 82G41 Integrated Graphics Device (rev. 0x03)
Intel product 2e33 (miscellaneous display, revision 0x03) at pci0 dev 2 function 1 not configured
kern info: [drm] Memory usable by graphics device = 512M
kern info: [drm] Supports vblank timestamp caching Rev 2 (21.10.2013).
kern info: [drm] Driver supports precise vblank timestamp query.
kern info: [drm] failed to find VBIOS tables
i915drmkms0: interrupting at ioapic0 pin 16 (i915drmkms0)
intelfb0 at i915drmkms0
intelfb0: framebuffer at 0xffffbd80af145000, size 1280x1024, depth 32, stride 5120
wsdisplay0 at intelfb0 kbdmux 1: console (default, vt100 emulation), using wskbd0
wsmux1: connecting to wsdisplay0

This one is basically unusable with the new Xorg (worked fine under
current before the update and works great under netbsd-8 native Xorg).

On first boot (prior to running 'etcupdate' and 'postinstall'), the screen
had a number of pastel rectangles over the 'xdm' login widget.  I used
<ctrl-R> to abort 'xdm', but that didn't seem to do anything.  I tried
to switch to a text console, but I only ever saw a black screen with a
block cursor in the corner.  Keystrokes echoed, but I couldn't tell if
they were doing anything.  I eventually had to hit the reset switch.

Rebooting in single-user mode, I disabled 'xdm' in "/etc/rc.conf" and
finished coming up so I could run 'etcupdate', etc.  Rebooting again,
I started 'xdm', but it never seemed to finish drawing the greeter.
It produced the gray panel and the logo graphic, but nothing else.
The bottom edge of the panel had glitches about 100 pixels long and
100 pixels apart.

The 'xconsole' window opened, but didn't seem to update unless I clicked
the mouse in the scroll bar.  Even then, the pixels "scintillated in" over
several seconds rather than being properly drawn.  It looked like it
was spewing (or trying to spew) some debug information.

Wary of getting hung by trying to abort 'xdm', I switched to the
first text console (which succeeded), logged in and rebooted--which
took an unusually long time to accomplish.

I have other machines with intel graphics to try, but it may be some
time before I can get to them.

|/"\ John D. Baker, KN5UKS               NetBSD     Darwin/MacOS X
|\ / jdbaker[snail]consolidated[flyspeck]net  OpenBSD            FreeBSD
| X  No HTML/proprietary data in email.   BSD just sits there and works!
|/ \ GPGkeyID:  D703 4A7E 479F 63F8 D3F4  BD99 9572 8F23 E4AD 1645

Home | Main Index | Thread Index | Old Index