Current-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Ill-behaved "libgthread" on local builds of -current

It's interesting to see a bulk build report from a system running
-current after so many months:

The last one was with amd64-7.99.31 from some time in September 2016.

What I still haven't been able to solve is why my locally-built releases
for i386, amd64 and macppc beginning with 7.99.32 persistently and
predictably cause "libgthread" to misbehave.  This breaks
"gobject-introspection" and therefore a host of other packages.  See PR
pkg/51266 for all the gory details.

Add "gdk-pixbuf2" and "json-glib" to the list of affected packages.

I've been able to work around the problem only by installing a snapshot
built on the TNF build cluster, wiping out all packages and building
everything from scratch.

The amd64 port is the most forgiving and I can build everything in my
usual complement of packages.  The problem packages noted in pkg/51266
can be built and rebuilt indefinitely as long as the system is updated
with snapshots from the TNF build cluster.  Once updated with a locally-
built release, all the problem packages fail to build.

The i386 port is more fragile and requires handholding and working around
MPROTECT gotchas, mostly with "gnutls" and accelerated assembly-language
versions of some crypto routines.

I haven't tried the macppc port in a while.

If any package fails due to "libgthread" going off into the weeds, the
system is poisoned and all attempts of subsequent packages to use
"gobject-introspection" during package builds fails.  To build any more,
the problem package that failed must be worked around, but all packages
have to be removed and everything built from scratch again.

Back in August, there was a question about the health of my machines.
All completed at least three passes of 'memtestplus' without error.
Several of the machines build the same set of packages for netbsd-7
(amd64 and i386) without issue.

Apparently only one (maybe two) other people are seeing this problem.
I'd like to find the problem and fix it.

Suggestions?  See pkg/51266.

|/"\ John D. Baker, KN5UKS               NetBSD     Darwin/MacOS X
|\ / jdbaker[snail]mylinuxisp[flyspeck]com    OpenBSD            FreeBSD
| X  No HTML/proprietary data in email.   BSD just sits there and works!
|/ \ GPGkeyID:  D703 4A7E 479F 63F8 D3F4  BD99 9572 8F23 E4AD 1645

Home | Main Index | Thread Index | Old Index