Current-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: systems with -current wm(4) hang?

On Fri, 27 May 2016, Kengo NAKAHARA wrote:

> These ethernet controllers apply to the condition which I think they
> can hung. However, hmm, there are many hung patterns unexpectedly.
> There can be another bug possibly...
> I expect for if_wm.c r1.409 to resolve the problem for all of above NICs.

Now using if_wm.c r1.410.

The amd64-class systems I've tested so far:

A Dell PowerEdge 2850 (amd64-class, PCI/PCI-X busses) with:

PCI/PCI-X built-in:
wm0 at pci6 dev 7 function 0: Intel i82541GI 1000BASE-T Ethernet (rev. 0x05)
wm1 at pci7 dev 8 function 0: Intel i82541GI 1000BASE-T Ethernet (rev. 0x05)

Booting from "wm0" still hangs, although it didn't do so until the system
tried to update fontconfig cache.

Booting from "wm1" completed startup and 'etcupdate'/'postintall'
operations.  Stress testing building packages hangs very shortly

An amd64-class machine (Dell Optiplex 760) with:

PCI-Express built-in:
wm0 at pci0 dev 25 function 0: 82567LM-3 LAN Controller (rev. 0x02)

Booting this interface consistently hangs during the update of
fontconfig cache.

PCI add-in card:
wm1 at pci4 dev 0 function 0: Intel i82541PI 1000BASE-T Ethernet (rev. 0x05)

Hung during fontconfig cache update.  Subsequent boot succeeded.  Stress
testing building packages hung rather soon after.

PCI-Express add-in card:
wm0 at pci1 dev 0 function 0: Intel i82574L (rev. 0x00)

booted without problems.  Stress testing building packages did not
provoke a hang during the time I ran it (around 12 hours).

The only i386 system I've tested so far:

A ThinkPad T42 with:

PCI built-in (daughtercard module):
wm0 at pci2 dev 1 function 0: Intel i82540EP 1000BASE-T Ethernet (rev. 0x03)

hangs during update of fontconfig cache.

Tests of other systems/cards to follow.

|/"\ John D. Baker, KN5UKS               NetBSD     Darwin/MacOS X
|\ / jdbaker[snail]mylinuxisp[flyspeck]com    OpenBSD            FreeBSD
| X  No HTML/proprietary data in email.   BSD just sits there and works!
|/ \ GPGkeyID:  D703 4A7E 479F 63F8 D3F4  BD99 9572 8F23 E4AD 1645

Home | Main Index | Thread Index | Old Index