Current-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: root on sd0a on odroid-c1

On 22 February 2016 at 12:46, Andrew Cagney <> wrote:
> On 20 February 2016 at 17:14, Michael van Elst <> wrote:
>> (Andrew Cagney) writes:
>>>so I simply added root=sd0a to /boot/boot.ini's boot line.  That resulted in:
>> [...]
>>>use one of: awge0 ld0[a-p] ddb halt reboot
>>>Should this have worked?
>> Apparently not, as there is no sd0a boot device.

Just FYI,

Tried a similar configuration on the Pi (i.e., same physical disk, but
did add ta powered USB hub), and it's working fine.  Hmm, perhaps it
is a power issue.


>>>However, I get the feeling that there's more going on.  For instance,
>>>just adding an entry to /etc/fstab to mount of /dev/sd0a on /mnt fails
>>>during boot (fsck can't access /dev/rsd0a during the boot).  Yet once
>>>the system is booted it works fine.
>> The USB disk is probably starting too slowly to be recognized at this
>> point. There needs to be some kind of spin-up delay in the kernel to
>> handle this situation.
> Ah.
> Is there any existing kernel event that would indicate a disk device
> has come on line?
> Andrew

Home | Main Index | Thread Index | Old Index