Current-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: failure

On Thu, Feb 04, 2016 at 09:25:18PM +0200, Andreas Gustafsson wrote:
> Patrick Welche wrote:
> > > How current was the host?
> > 
> > Mine is Jan 28th.
> UTC?  There were less than 19 minutes on the 28th UTC when the tree
> even built...

Not sure, as it was from the timestamp on /bin/ls, so cvs, build...

> My test of building today's current on itself (source date
> 2016. finally completed, and it worked.
> In an earlier test, a -current from 2016. failed to
> build itself, but it failed with with a different error than yours:
>   /usr/src/tools/libctf/../../external/cddl/osnet/sys/sys/types.h:118:1: error: unknown type name 'vsize_t'
> Anyway, it looks like -current was having some issues as a build host
> around that time, and that upgrading to today's -current will likely
> help.

Oddly, I ended up fixing this by copying /lib/ from another
box (and /usr/lib/crt* just in case). Thereafter tools worked
again, and I managed a successful build. Thanks for the positive reports!



Home | Main Index | Thread Index | Old Index