Current-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Sysbuilld cron under -current amd64

On 27 January 2014 00:59, Chavdar Ivanov <> wrote:
> On 26 January 2014 22:38, Christos Zoulas <> 
> wrote:
>> In article 
>> <>,
>> Chavdar Ivanov  <> wrote:
>>>(newbie alert...)

>>>I build -current amd64 and i386 using sysbuild overnight. This used to
>>>work (modulo the usual temporary breaks, of course), but has been
>>>failing lately with:
>>>--sysroot=/home/sysbuild/Sysbuild/amd64/destdir     -o rain  rain.o
>>>path-link,/home/sysbuild/Sysbuild/amd64/destdir/lib  -L=/lib -lcurses 
>>>sh: Cannot vfork

Now I am getting (resource temporarily unavailable) when it fails.

It seems it is not because of being ran by cron, but because of
/bin/sh - it worked for me interactively, because I 'su - sysbuild'
and then always exec zsh before starting the sysbuild process. This
afternoon I got the failure message interactively - using /bin/sh, not
exec-ing zsh.


>>>*** [rain] Error code 2
>>>nbmake[7]: stopped in /home/sysbuild/src/games/rain
>>>1 error
>>>If I manually run the exact cron command as the sysbuild user:
>>> /usr/pkg/bin/sysbuild4cron -l "${HOME}/log" -- build
>>>it runs OK (again. modulo the usual breaks), so it looks like a
>>>resource constraint when running under cron, which I can't figure out
>>>(or,, more likely, am lazy to locate the FM to read it...).
>>>The system is Xen guest with six cores and about 1.2GB memory, NJOBS
>>>is set to 12.
>> I added some more info in the error message.
> I see the changes; I ran the build manually OK just before them; the
> cron-started run had only these two files modified, ran OK to the end.
> Hopefully one of the next builds will show up - I'll update the
> machine now to get the modified shell.
> Chavdar
>> christos
> --
> ----


Home | Main Index | Thread Index | Old Index