Current-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Building on -current fails in cleandir

D'Arcy J.M. Cain wrote:
>On Sat, 13 Oct 2012 12:25:20 +0200
>Alan Barrett <> wrote:
>> On Fri, 12 Oct 2012, D'Arcy J.M. Cain wrote:
>> >I have been getting this on -current for a few days now.  I am
>> >surprised that no one else has mentioned it.  Is this indicative of a
>> >problem in my own setup?  I have rebuilt the tools every day while
>> >trying to build this.
>> >
>> >#    objdir  /usr/obj/usr/NetBSD/cvs/src/compat/amd64/i386
>> >obj ===> compat/amd64/i386
>> >obj ===> compat/amd64/i386/../../../lib
>> >
>> >*** Failed target:  obj-../../../lib
>> This looks as though your src/share/mk is not up to date.  Or 
>> perhaps you tried to build by just running "make" with whatever 
>> /usr/share/mk you happened to have installed on the host system 
>> instead of using or ${TOOLDIR}/bin/nbmake-${MACHINE}.
>Nope.  I do a CVS update on my tree daily and I clean out my WRKOBJDIR
>and DESTDIR (which is $WRKOBJDIR/destdir), run "./ tools" and
>then "./ build".  The tools build OK as does a kernel but not
>the userland build.

Have you tried doing just "./ build" after cleaning out
old directories ? The tools target will get built as part of this.

It may be that everyone else uses explicit obj and destination paths,
this works fine for me.

Robert Swindells

Home | Main Index | Thread Index | Old Index