Current-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Installation of NetBSD 5.99.44 and resulting problems

from Matthew Sporleder:

> Were you able to try vbetool or xset?  Also trying some of the other
> tips in the bug report like using different color modes (16bpp) or the
> patch in there?

I finally tried vbetool for both NetBSD 5.1_STABLE and 5.99.44, did 5.1_STABLE 
first because that's where pkgsrc is installed and I needed to run 

cvs update -dP

first.  Anyway, I noticed that the pkgsrc version of vbetool is behind: 
0.7.1nb2 vs. the current release 1.1 .

vbetool worked partially in NetBSD 5.1_STABLE.  I still got the screenblank 
problem, so I have to keep a root console available at all times to be able to 

screenblank -u

but, by running "vbetool vbemode get" before going into X, and "vbemode vbemode 
set" (followed by mode revealed by vbetool vbemode get), I got back the 
text-mode console.  I booted with "boot netbsd -2a" so I don't know if this 
success requires disabling ACPI: more testing needed.

I bootstrapped pkgsrc for NetBSD 5.99.44 on USB stick, using same pkgsrc on 
hard drive but with work directory "work599" instead of "work51".  Then I was 
successful building vbetool.  But running vbetool as root, I got "Permission 

mmap /dev/mem: Permission denied
Failed to initialise LRMI (Linux Real-Mode Interface).

I can't see why I got this message on 5.99.44 but not 5.1_STABLE.

I was still able to run "shutdown -r now", even though I couldn't see anything 
on the screen until I was out of NetBSD and into reboot.


Home | Main Index | Thread Index | Old Index