Current-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Installation of NetBSD 5.99.44 and resulting problems

On Mon, Jan 31, 2011 at 5:59 AM,  <> wrote:

> I built kernels with r128fb and with no framebuffer.  In all cases, I could 
> startx (twm), but when I exited, text console was all dark and could not be 
> restored (shutdown -r now worked even though I couldn't see anything on the 
> screen).
> Also, when I booted the kernel with r128fb after enabling vesa mode 0x322, 
> and also 0x101, and subsequently booting netbsd-r128fb, screen almost 
> immediately went blank, with either mode 0x322 or 0x101, though apparently 
> the boot went through invisible to me.  I was able to login as root and type 
> the password, and subsequently shutdown -r now with no sight of the screen: 
> not usable that way, but I got out clean.  I wonder if anybody has succeeded 
> getting vesa framebuffer to work.

I wonder if vbetool could fix your blank screen after exiting X.  Also
did you try changing the screen brightness and switching to different

I have used the vesa framebuffer successfully and had similar problems
if I attempted an incorrect mode.  I believe I used another machine to
ssh into the box in question as I figured it out/looked at dmesg
output.  Sorry I don't have more specifics, it's been a few years
since I tried it.

Home | Main Index | Thread Index | Old Index