Current-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Installation of NetBSD 5.99.44 and resulting problems

I installed NetBSD 5.99.44 on a 4 GB USB stick via the Internet, 

after downloading boot-big.fs .

I booted boot-big.fs as a floppy image using grub4dos running under FreeDOS; 
this was successful.

I don't think this was the intended way to boot such too-big-for-floppy images, 
but it worked.

Installation took 2 1/2 hours, surprisingly fast considering the USB stick is 
so much slower than hard drive.

Next night, I downloaded the source, /usr/src and /usr/xsrc , using cvs 
checkout, this was also surprisingly fast, about 2 hours.

I remember, from NetBSD 4.0 and 4.0.1, how slow extracting .tgz files was on a 
USB stick, took over 7 hours extracting from already-downloaded .tgz source 
sets.  I have 5.1_STABLE on hard drive.

I had 600 MB space left after all this, with NetBSD 5.99.44, enough to rebuild 
the kernel, and even some packages if I have and use pkgsrc on a hard drive, 
where I have NetBSD-5.1_STABLE installed.

I built kernels with r128fb and with no framebuffer.  In all cases, I could 
startx (twm), but when I exited, text console was all dark and could not be 
restored (shutdown -r now worked even though I couldn't see anything on the 

Also, when I booted the kernel with r128fb after enabling vesa mode 0x322, and 
also 0x101, and subsequently booting netbsd-r128fb, screen almost immediately 
went blank, with either mode 0x322 or 0x101, though apparently the boot went 
through invisible to me.  I was able to login as root and type the password, 
and subsequently shutdown -r now with no sight of the screen: not usable that 
way, but I got out clean.  I wonder if anybody has succeeded getting vesa 
framebuffer to work.

Subsequently I booted into Linux, using vga=ask, went for the same video mode, 
and it worked, and for the first time ever, I ran links web browser using the 
framebuffer (fb) graphic driver.  I wanted to verify that the particular 
videomode was compatible with my monitor.

I don't have the time to keep up with every update of NetBSD-current, but if 
something promising comes up, I might try again, otherwise not.

What is the best way to update?  Boot that giant-floppy image from FreeDOS and 
grub4dos, using the update function of sysinst?  I would update the source 
using cvs update -dP.

If things really look promising, and I want bigger things, I will need to go to 
a bigger USB stick, at least 8 GB, at least on present computer.


Home | Main Index | Thread Index | Old Index