tech-x11 archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

After update, !X. Reinstalled backup: still !X. Argh!

What hell have I maneuvered myself into?

I have updated from NetBSD 5.1RC2 and pkgsrc modular-xorg-server
(and actually all of my pkgsrc packages) from pkgsrc-2010Q2 to
NetBSD 5.1RC4 and recent pkgsrc off the 2010Q3 branch.

After the update, X won't start. It seems the BusID addressing
scheme changed, so I updated the BusIDs. Now X will only give me
a black screen, the computer eventually starts beeping, and I can't
switch vts (never could though, this is with the nv driver).

So I thought I'd deal with the breakage later and removed all
packages and reinstalled the backup I made before the update with

Still no luck - after changing the BusIDs in my xorg.conf again to
the old style, black screen.

So I thought, well, this is gotta be related to RC2->RC4 and I
installed both RC2 kernel and userland again. Still with the
previously installed (and working) packages.

Well, X still makes the screen go black and essentially render the
computer unusable.

I tried with 5.0.2 and old and new pkgsrc packages ... still
no luck. Actually what I tried was:
(with ACPI; without ACPI) x (5.0.2 ; 5.1RC2 ; 5.1RC4) x 
        (pkgsrc-2010Q2; pkgsrc-2010Q3) x 
        (NoInt10 True;NoInt10 False;InitPrimary True;InitPrimary False)
(yes that's a lot of combinations. No, I didn't get any work done today)

I'm at loss here.. and desperate to be honest, because this is my
work machine and I got to get work done...

I've tried to assemble all sorts of information about the computer,
sadly I have neither dmesg, sysctl output, acpidump or log
from when it was working.

some info at a glance about the computer:
It's a Dell precision T5400 workstation with 4G of ram
(note that NetBSD insists on it having 3Gs - even if
REALMEMEXT is set to the correct value).
It has a NVIDIA Quadro NVS 290 graphics card with the 
splitwhip, two monitors attached. (as it's essentially
four outputs, I can't not use the BusID).
It's running i386 NetBSD off the -5 branch, and previously
w/o problem for 1.5+ years.

When looking at the Xorg log's, you'll notice it hangs after int10
initialization. Even when using NoInt10 option, it uses it nonetheless
and happily hangs afterwards.  InitPrimary toggling doesn't help
anything either.

Here's a couple of logfiles and other information about the box:

dmesgs from 5.0.2 and 5.1_RC4:

Xorg logs from 5.0.2 and 5.1_RC4:

An acpidump: (Note it says some moral equivalent of RST obj 7 :
checksum error when using acpidump):

sysctl output for hw, machdep, kern (funny how it reports biosextmem
"correctly" to the value I forced in this kernel as opposed to what
the dmesg is saying: 309x MB of ram)

Here's the "new" and "old" xorg.conf's.

What really baffles and bothers me is that the exact same configuration
that worked fine before the update (5.1RC2, old pkgsrc, "old"
xorg.conf) is NOT working anymore. ISTM some non-volatile values
in the graphics cards have been overwritten by either the nv
driver/ or by the newer NetBSD - wtf?!

Please help saving this box from the impending doom of being run
under an inferior OS that runs X successfully.

Thanks in advance!


Home | Main Index | Thread Index | Old Index