tech-userlevel archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: 5.1 vs. 6.0_BETA

On Sat, Feb 25, 2012 at 04:21:06PM +0100, Manuel Bouyer wrote:
> > It doesn't matter IMHO whether it is expected or not. It is simply
> > not acceptable. Backwards compatibility has always been and still
> > is an important goal for NetBSD.
> Sure. I think this has to be fixed before 6.0_BETA can be officially
> announced.
> Could bumping the major number of these libraries be an alternative
> to exporting __cerror again ? What are the pros and cons of each
> fix ?

The cons against bumping the major is that it won't fix system
that have already been upgrade to NetBSD 6.0_BETA. The user
would have to manually install a "librt" from e.g NetBSD 5.1.2.

        Kind regards

Matthias Scheler                        

Home | Main Index | Thread Index | Old Index