tech-userlevel archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: 5.1 vs. 6.0_BETA

On Sat, Feb 25, 2012 at 12:51:57AM +0300, Aleksey Cheusov wrote:
>  >> Does NetBSD keep libraries from base (except X11 libs)
>  >> backward compatible between major releases?
> > Yes, that is the goal.
> After updating the system from 5.1 to 6.0_BETA I've found that a lot of
> applications built for 5.1 stop working due to lack of __cerror in libc.
> mediatomb, for example, says
>     /usr/lib/ Undefined symbol "__cerror" (symnum = 12)
> This change probably comes from here
> Is this breakage expected?

It doesn't matter IMHO whether it is expected or not. It is simply
not acceptable. Backwards compatibility has always been and still
is an important goal for NetBSD.

Can you please submit a PR and notify release engineering about
the problem?

        Kind regards

Matthias Scheler                        

Home | Main Index | Thread Index | Old Index