tech-userlevel archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: libevent (1.4.12-stable) -> external/bsd

On Wed, 28 Oct 2009, Thor Lancelot Simon wrote:

> On Wed, Oct 28, 2009 at 05:33:07PM +0000, Iain Hibbert wrote:
> > On Wed, 28 Oct 2009, Thor Lancelot Simon wrote:
> >
> > > Didn't I already pick up the only relevant 1.4.12 change by hand?
> >
> > Perhaps - the only post-import change I saw was the addition of
> > -fno-strict-aliasing and I didn't examine the rest of the differences
> > beyond superficially.
> >
> > Truly there isn't much change but I'm also interested in the
> > maintainability of pushing it into external/ where a replacement can be
> > made easily rather than having it spread over the source tree..
> I'm not sure it's a good idea to move it to external if most of the work
> will just have to be done again for 2.0.

Well, most of the work is in the move to external/ but I can look at 2.0
afterwards - I don't think we should import an alpha release but it builds
without much trouble and I will look about feeding back the lint and
compiler errors so it will be easier to bring in later.

> Most libevent users seem to be using 2.0 now.

do you have any direct experience of the source compatibility?  The only
references I see in src/*bin are bthset, bthcid, btpand, ftp-proxy and
syslogd and only ftp-proxy is using an 'advanced' API (bufferevent)


Home | Main Index | Thread Index | Old Index