tech-toolchain archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: useless /usr/tests tree for MKATF=no builds

On 12/2/10 9:58 PM, Nicolas Joly wrote:
On Wed, Dec 01, 2010 at 09:20:01AM +0000, Julio Merino wrote:
On 11/29/10 8:03 PM, Nicolas Joly wrote:
While previously some shell tests could be run mannually, we can't now
because the interpreter switched to /usr/bin/atf-sh (since ATF 0.9).
Other test that require c/c++ APIs are not even built ... Only remains
a few input/results files.
Which shell tests could be run without atf?  (Just curious because I
can't imagine how that worked!)
I must confess that i never really checked them in that case ... But
at least, at that time, they could be started even if they failed
early because of missing atf-check tool by example; now they won't
even start.
Yeah, they could be started... but I don't see how they could do anything useful! Those scripts required to source the atf-sh library, which I assume it is not present with MKATF=no. (That said, the scripts did not use 'set -e' before and they did not have enough error handling... which means that most errors would go unnoticed! This could have caused the impression that things mostly worked.)

Home | Main Index | Thread Index | Old Index