tech-pkg archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Update default version of PHP and Ruby?

* On 2017-03-17 at 15:42 GMT, Takahiro Kambe wrote:

> What about to bump default version of PHP and Ruby before branch?
> 	* PHP 5.6.x to PHP 7.0.x.
> 	* PHP 7.0.x is active and well maintained version for now.
> Ruby
> 	* Ruby 2.2.x to Ruby 2.3.x.
> 	* Ruby 2.2.x and 2.3.x are well compatible and I think now
> 	  Ruby 2.3.x is most stable and well maintained version.

We (Joyent) switched to Ruby 2.3 for our 2016Q4 package set.

I didn't bump PHP as at that time there were fewer modules available
for 7.0 compared to 5.6 and it was reasonably new to pkgsrc.  Looking
at the most recent trunk build, it's still behind 5.6 (122 vs 137).

So for Ruby I'm happy to see that happen.  For PHP I have no strong
opinion either way.

Jonathan Perkin  -  Joyent, Inc.  -

Home | Main Index | Thread Index | Old Index