tech-pkg archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: "sa-update" in SpamAssassin 3.4.0

On Mon, Apr 28, 2014 at 11:39:48AM -0400, Greg Troxel wrote:
> Matthias Scheler <> writes:
> > I'm currently leaning toward using "TOOLS.curl" or "TOOLS.fetch" if set
> > and otherwise use the "wget" package (which has less dependences than
> > the "curl" package").
> SA is big enough taht depending on wget or curl shouldn't help.
> I'm not sure what you mean by TOOLS; this use isn't a TOOL use.  But
> choosing the run-time dependency based on what TOOLS are available seems
> like a reasonable approach.

I'm checking whether "curl" or "fetch" are pre-installed and use them
if they are.

> The other approach is just to pick one,
> which removes a cause of variation that could cause trouble.

The package does that. I've completely removed the auto-detection code.

> curl is smaller; 1.9 MB on i386, and with libidn 2.8 MB.

Smaller that what? "wget"? I thought it was the other way around.

        Kind regards

Matthias Scheler                       

Home | Main Index | Thread Index | Old Index