tech-pkg archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: mit-krb5/ problems on solaris

I think that bump of should be reset,
it is the right solution.

Bump of is correct, because ABI of
libraries had been changed since 1.8.x.

In pkgsrc, only security/mit-krb5-appl depend on security/mit-krb5 directly.
others are using Kerberos through mk/
For example, heimdal will be used instead mit-rkb5 for NetBSD by default,
and BUILDLINK_API_DEPENDS.heimda is 0.4e, i.e. too lower.
I don't know about mit-krb5 API changes from 1.4.x to 1.8.x, but I never seen
krb5 API issue on any of packages with builtin heimdal on NetBSD, and
it represent that any of packages require mit-krb6 1.8 API.

If does not exist for a package, it is not so terrible to
maitain BUILDLINK_API_DEPENDS, because multiple version packages will be never 
and BUILDLINK_ABI_DEPENDS will support it.
On the other hand, if exists, multiple versions may be mixed 
(builtin and pkgsrc),
and BUILDLINK_ABI_DEPENDS will not help it, because it will be ignored for 
builtin one.
To avoid such situation, BUILDLINK_API_DEPENDS must be managed carefully, for 
example, minimum required
version in whole pkgsrc, or majority.

Bump of BUILDLINK_API_DEPENDS is not wrong, but KRB5_DEFAULT=mit-krb5 is just 
on HP-UX, Darwin and SunOS
by default in pkgsrc, so I feel it is better to allow builtin mit-krb5 on SunOS.
I heard that bulk build of SmartOS is set as PREFER_PKGSRC=yes, so such 
will not be affected (pkgsrc's one will be always used).

On Mon, 23 Sep 2013 21:35:47 +0900, Tim Zingelman <> 

I have never understood why in pkgsrc a package defines its own
minimum version.  Each other package which requires mit-krb5 should be
expressing the minimum version it finds acceptable.  This is why when
I updated mit-krb5 to 1.8.x and bumped BUILDLINK_ABI_DEPENDS and then
someone saw this exact issue and asked that I change it back, I did
so.  In retrospect I should have added a comment to the
file explaining the situation.  Sorry about that.  I would suggest
reverting it to mit-krb5>=1.4nb1 as it was, and if any dependent
package breaks, fix it in there.

 - Tim

On Mon, Sep 23, 2013 at 6:52 AM, Jonathan Perkin <> 
* On 2013-09-23 at 12:33 BST, OBATA Akio wrote:

See also PR pkg/44597...

Thanks.  What I will probably do is lower the requirement in our
2013Q3 release branch and see what happens, then we can decide whether
to do the same in pkgsrc later (or perhaps make it OPSYS-specific).

Input from Kerberos hackers would be appreciated.

Jonathan Perkin  -  Joyent, Inc.  -

OBATA Akio /

Home | Main Index | Thread Index | Old Index