tech-pkg archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: mit-krb5/ problems on solaris

Le 23/09/13 12:13, Jonathan Perkin a écrit :
* On 2013-09-21 at 13:56 BST, Richard PALO wrote:

I've noticed difficulties getting native mit-krb5 detected on the
SunOS I'm running...

Already, by inspection there is one problem in getting the version
because of solaris putting the version indication between parens...

On this version of OI:
richard@x3200:~/src/pkgsrc/mk$ krb5-config --version
Solaris Kerberos (based on MIT Kerberos 5 release 1.6.3)

I believe this patch fixes that:
richard@x3200:~/src/pkgsrc/security/mit-krb5$ git diff .
diff --git a/security/mit-krb5/ b/security/mit-krb5/
index c31837d..c3e754e 100644
--- a/security/mit-krb5/
+++ b/security/mit-krb5/
@@ -39,7 +39,7 @@ MAKEVARS+=
.  if empty(SH_KRB5_CONFIG:M__nonexistent__)!=     ${SH_KRB5_CONFIG} --version | \
-                               ${SED} -e 's/.*release //' -e 's/-.*//'
+               ${SED} -e 's/.*release //' -e 's/-.*//' -e 's/).*//'
.  endif     1.4.0          mit-krb5-${}

But that isn't the problem...

This bit is correct, we should add it.

Even though it should be on by default on SunOS, I also added
'mit-krb5' to PREFER_NATIVE= and even added KRB5_DEFAULT=mit-krb5


The problem is that the default version was bumped to require at least
1.8, whilst the native version is at version 1.6.3, so even though
pkgsrc finds the builtin version (you can verify this with 'show-var') it rejects it based on the version.

As both API and ABI depends use 1.8 it suggests that older versions
cannot be used at all, however you may want to try downgrading the
version requirement in in your local checkout.

Someone who knows the mit-krb5 code better could advise on whether we
need the hard requirement on >=1.8 or if the older versions can
actually be used.

That was it, I tried setting to 1.6 in and it now finds it okay.

What is a bit misleading is the default of 1.4 in

It would be extremely kind to relax the minimal requirement if at all possible.

Thanks Jonathan.

Home | Main Index | Thread Index | Old Index