tech-pkg archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: ghostscript meta package

On Sat, 20 Apr 2013, David Sainty wrote:

> David Holland <> wrote:
> >On Thu, Apr 18, 2013 at 08:27:27PM +1200, Steven Drake wrote:
> > > Does anyone have a problem with changing the way the 
> >> ghostscript-agpl/ghostscript-gpl is selected to use a meta-package
> >named
> > > 'ghostscript' that depends on one of them.
> I'm not a big fan of the by-licence selection though, given that it 
> essentially defaults to the less-maintained version, and it's extending 
> the licence functionality to new ground - elsewhere licensing settings 
> don't change the package set on the machine, but here they do. That 
> could be seen as abuse.

The meta-package doesn't use by-licence selection, it uses the PKG_OPTIONS
framework so that the use can choose which one they want. 

$ cd print/ghostscript ; make show-options
Any of the following general options may be selected:
At most one of the following ghostscript options may be selected:

These options are enabled by default:

These options are currently enabled:

You can select which build options to use by setting PKG_DEFAULT_OPTIONS
or PKG_OPTIONS.gs_type.


Home | Main Index | Thread Index | Old Index