tech-pkg archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: gsed:run not working

On Sat, May 7, 2011 at 11:29 AM, Joerg Sonnenberger
<> wrote:
> On Sun, May 08, 2011 at 12:52:21AM +0900, OBATA Akio wrote:
>> On Sat, 07 May 2011 23:42:18 +0900, Tim Zingelman <> 
>> wrote:
>> >No, but I know other aspects of USE_TOOLS are broken (or not matching
>> >documentation) for a while, but I have not found time to look at it.
>> >See for an example of
>> >USE_TOOLS+=diff:pkgsrc not working.
>> I feel diff:pkgsrc in USE_TOOLS dose not mean that the package require diff 
>> from pkgsrc,
>> It means just diff is used by pkgsrc infrastructure, i.e. hidden build 
>> dependency.
> Exactly.
> Joerg

So just to be clear, what is the correct way to specify that pkgsrc
version of diff is needed in the make install phase for a package such
as databases/mysql51-client to fix that PR?  Is the 'make install'
phase considered runtime vs. build?  (There are at least a couple open
PR's on this kind of problem.)


 - Tim

Home | Main Index | Thread Index | Old Index