tech-pkg archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: default PHP to 5.3?


On Mon, 20 Dec 2010 17:59:00 +0900, Takahiro Kambe 
<> wrote:

In message <>
        on Mon, 20 Dec 2010 16:51:05 +0900,
        "OBATA Akio" <> wrote:
As release of php-5.2.16, "This release marks the end of support for
PHP 5.2",
so should we switch default PHP in pkgsrc to 5.3(lang/php53)?
I'm not sure when we switch.

For maintain pkgsrc-2010Q4 branch, I feel it should be switched before 2010Q4 

Or update lang/php5 to 5.3.x and drop 5.2 support?
I object to change content of lang/php5 to 5.3.x.

        * If we nuke 5.2, simply remove php5.
        * If PHP 5.4 released, add lang/php54.

So we could keep php53, php54, and so on and keep common stuff under
lang/php or mk?

If we will keep to maintain multiple php5 branches,
I feel it is reasonable approach.

OBATA Akio /

Home | Main Index | Thread Index | Old Index