tech-pkg archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: archivers/xz

If I understand pkgsrc correctly, you aren't missing anything, although
I've only ever done things the other way around and tried to add a new

You always need to set "USE_XZ=yes" because xz really is a dependency
and pkgsrc will build or not build archivers/xz as is generally
appropriate. e.g. for OSes that don't have xz built in.

My understanding is that "PREFER.xz=pkgsrc" is specifically for cases
like this where we know that the built in version is not what we want.
Maybe just add a conditional around "PREFER.xz=pkgsrc" so that it is
only set for NetBSD.


This email and any attachment may contain confidential information.   If you 
have received this email or any attachment in error, please delete the email / 
attachment, and notify the sender.  Please do not copy, disclose or use the 
email, any attachment, or any information contained in them. Consider the 
environment before deciding to print: avoid printing if you can, or consider 
printing double-sided.

Home | Main Index | Thread Index | Old Index