tech-pkg archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Requirements update for some Perl-Packages

2010/9/23 Greg Troxel <>:
> Jens Rehsack <> writes:
>> Hi all,
>> I update currently the last p5-* packages before the freeze and have a
>> dependency problem:
>> 1) math/p5-Math-BignInt-GMP needs Math::BigInt >= 0.90
>> 2) editors/p5-Padre needs threads::shared >= 1.33
>> Both dependencies are usually Perl5 core modules and not packaged separately.
>> I don't want to import them, because usually the module versions in
>> the core are big enough.
>> I intend to update lang/perl5 to 5.12.2nb1 and patch threads,
>> threads::shared and Math::BigInt
>> to the current CPAN versions.
> (Moving to 5.12.2 seems fine to me.)

We are already on 5.12.2 (if nothing scrambled the commit)

> I don't understand well enough to object, so these are just questions
> and *not* an objection.
> It seems odd that we have to take patches from CPAN and put them into
> perl.  It seems kind of buggy that programs need higher versions of
> things that are in perl base than the latest released stable perl.

The intended patches are primarily fixes, not feature enhancements.
So patching those would increase stability of the perl base.

> What are other systems (freebsd, openbsd, ubuntu, etc.) doing about this?

Having completely depreciated packages. The Ubuntu users I know from don't use Ubuntu packages, they install directly from CPAN.
This includes threads, threads::shared etc. are installed in another version
than the bundled version in $perl_lib/sitelib. If we (or I) do this, this will
increase maintenance overhead, require more CONFLICTS being added
to lang/perl5/Makefile etc.

I wouldn't recommend that.


Home | Main Index | Thread Index | Old Index