tech-pkg archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Requirements update for some Perl-Packages

Jens Rehsack <> writes:

> Hi all,
> I update currently the last p5-* packages before the freeze and have a
> dependency problem:
> 1) math/p5-Math-BignInt-GMP needs Math::BigInt >= 0.90
> 2) editors/p5-Padre needs threads::shared >= 1.33
> Both dependencies are usually Perl5 core modules and not packaged separately.
> I don't want to import them, because usually the module versions in
> the core are big enough.
> I intend to update lang/perl5 to 5.12.2nb1 and patch threads,
> threads::shared and Math::BigInt
> to the current CPAN versions.

(Moving to 5.12.2 seems fine to me.)

I don't understand well enough to object, so these are just questions
and *not* an objection.

It seems odd that we have to take patches from CPAN and put them into
perl.  It seems kind of buggy that programs need higher versions of
things that are in perl base than the latest released stable perl.

What are other systems (freebsd, openbsd, ubuntu, etc.) doing about this?

Attachment: pgpB5sbjCcN1U.pgp
Description: PGP signature

Home | Main Index | Thread Index | Old Index