[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]
Re: Patch name changes
On Thu, Jun 10, 2010 at 01:14:33PM +0200, Thomas Klausner wrote:
> I would like to suggest that we change the names used for patches in
> Currently, their names are patch-[a-z][a-z] where the names are more
> or less chosen randomly; when upgrading, usually care is taken to use
> the same patch name to modify the same file as before (mkpatches(1)
> from pkgtools/pkgdiff does that automatically).
> I suggest we starting from now on, we use the name
> patch-path_relative_to_wrksrc_filename instead, i.e. run the path of
> the name of the file to patch through
> sed -e "s,_,__,g" -e "s,/,_,g"
> and prefix "patch-".
Interesting syntax - is there any prior art for this kind of naming scheme?
Maybe a RFC 1738/VIS_HTTPSTYLE (see strvis(3)) transformation would be
appropriate rather than something new? It might not be as visually
obvious, I don't know - some examples would be nice here :-).
Main Index |
Thread Index |