tech-pkg archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: make package weirdness in pkgsrc-2010Q1

Joerg Sonnenberger <> writes:

> On Tue, Apr 13, 2010 at 10:40:09PM -0400, Louis Guillaume wrote:
>> With DEPENDS_TARGET=package. It's worked that way for years. I've
>> never set UPDATE_TARGET before.
> Use package-install. I explicitly opted out from magically fixing that
> up. Note that it is not needed to set it if you always run make package
> or make package-install.

I agree with not having any magic fixups.  But arguably
DEPENDS_TARGET=package should cause an error with USE_DESTDIR=yes.
Perhaps anything other than "install" or "package-install".  Without
DESTDIR, legitimate values are "install", "package" and

Another view is that DEPENDS_TARGET and UPDATE_TARGET are needlessly
complicated.  Basically you always want an installed package, and the
only question is whether you want a binary package (of course with
destdir you get one anyway).  So maybe both should go away (and be an
error if set) and be replaced with:


to turn on asking for packages.

Attachment: pgpLfqI5L3XbG.pgp
Description: PGP signature

Home | Main Index | Thread Index | Old Index