tech-pkg archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: packages conflict with themselves / pkgin conflict with same version

On Sat, Sep 26, 2009 at 06:33:02AM -0500, Jeremy C. Reed wrote:
> libglade-2.6.3 (to be installed) conflicts with installed package 
> libglade-2.6.3.
> proceed ? [y/N] 
> Some packages are broken this way:
> /var/db/pkg/libglade-2.6.3/+CONTENTS:@pkgcfl libglade-[0-9]*
> libglade/Makefile has:
> CONFLICTS+=             libglade-[0-9]*
> It conflicts with itself!

That's a bug. It comes from the time when the package was called
"libglade2" and conflicted with "libglade", and when I changed its
name over two years ago, I missed updating the line.
I've just fixed it, thanks for the bug report!

Home | Main Index | Thread Index | Old Index