tech-pkg archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: packages conflict with themselves / pkgin conflict with same version

On Sat, 26 Sep 2009 20:33:02 +0900, Jeremy C. Reed 
<> wrote:

So maybe pkgsrc packages should not conflict with themselves.

But if py??-foo conflicts each other, I probably mark package "py-foo" as
CONFLICTS+= py[0-9][0-9]-foo

As a workaround, maybe pkgin could ignore conflicts of own package. But
I think not, as I can use it to catch this problem later.

maybe pkgin treat as SUPERSEDES of own package first.

"Of course I love NetBSD":-)
OBATA Akio /

Home | Main Index | Thread Index | Old Index