[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]
Re: pkg_add and remote packages
On Mon, 07 Apr 2008, Johnny C. Lam wrote:
> Gems express dependencies using the following operators:
> (none) any version is okay
> =1.1 exactly version 1.1 is required
> >=1.0 at least version 1.0
> <2.0 less than version 2.0
> ~>1.1.5 any version at least 1.1.5 where last number can change
> The last operator [...] is a very nice expression that we should put
> into pkgsrc dependencies.
Can't pkgsrc already express that, via ">=1.1.5<1.2" (which I find
easier to understand)?
--apb (Alan Barrett)
Main Index |
Thread Index |