tech-net archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: link negotiation issues on re(4)/rgephy with new switch

On 5/9/2012 9:51 AM, Jeff Rizzo wrote:
I bought a new (well, used) Netgear GS784T switch, and went to plug my
Xen DOM0 box into it, only to find out the ethernet interface (re(4))
wouldn't come up... it shows "no carrier" when I check ifconfig output.
I tried various things, rebooting, etc., but I couldn't get it to come
up.  (the switch port and cable, of course, works fine on other
systems).  Thinking there might be an issue with rgephy, I built a
kernel without (xen dom0 doesn't seem to support userconf, so I couldn't
just disable it), and tried that.  It fails in very much the same way,
*except* that right after a reboot, it sort-of comes up:

mtu 1500

     address: bc:ae:c5:de:7f:d4
     media: Ethernet autoselect
     status: active
     inet netmask 0xffff0000 broadcast
     inet6 fe80::beae:c5ff:fede:7fd4%re0 prefixlen 64 scopeid 0x1

...but it doesn't negotiate 1000baseT full-duplex, as I would expect
(and as it does with the old switch).

Does anyone have any further troubleshooting suggestions?


The managed Netgear switches I've seen have several power-saving modes, some related to autodetecting cable length. Perhaps they have been enabled and are functioning improperly for you?


Home | Main Index | Thread Index | Old Index