tech-kern archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]


On Tue, Jun 02, 2009 at 02:10:06PM +0300, Jukka Marin wrote:
> I have been using a setup where my $HOME is located on a NetBSD NFS server
> (for 10+ years).  Every now and then something goes wrong with NFS and
> all accesses to /home cause the process enter disk wait (D in ps listing).
> No matter how long I wait, the disk wait never completes.  I can't even
> shutdown and reboot the client system properly because shutdown fails
> to unmount the NFS partition(s).  At the same time, all other NFS mounts
> from the same server work just fine.

I'm using a blunt version of NFS: just plain
/bulky          -network
/bulky          -network iipv6::/64

in the /etc/exports and invoked with:

nfs_client=YES  # not needed normally
nfsd_flags="-6 -u -t -n 6"

in /etc/rc.conf

hostname:/usr/sources /usr/sources nfs rw,noauto 0 0

on the clients; no magic there :)

> All I did was launch firefox3 and bang, /home was dead.

I can run firefox3 without any problems here... wonder what causes it.

> So, what's up with NFS?  Will it ever be fixed?  It's been the same
> for years and for many NetBSD releases.  Am I supposed to be running
> samba between NetBSD systems?

What are you refering to? Its working fine here with 5.0 and -current machines
mixed. There used to be some issues on NetBSD 1.6 AFAIR but those were solved
in 2.0.

> Here's how I mount /home in case I'm using wrong options (I have tried
> many combinations with no luck):
> server:/home    /home   nfs     rw,-X,-i,-b,-s,-C,-x16  0 0

Arguably i should/could use -s myself too....

With regards,

Attachment: pgpwx0lZ9RKs8.pgp
Description: PGP signature

Home | Main Index | Thread Index | Old Index