tech-kern archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: partitioning >2TB?

>> disklabel itself is, of course, not suitable because of its 32-bit
>> limits.  So I started looking at wedges, [...]
> Any reason why you don't use GPT?  That might be the most comfortable
> option.

I thought GPT was just the on-disk storage format underlying wedges.
Was (is) that impression wrong?  Perhaps GPT is a good option.

I tried playing around with gpt(8) but wasn't able to figure out what I
needed to tell it to get what I wanted.  Perhaps I just didn't try the
right thing; the manpage, like most manpages, is a fine reference
document but a horrible tutorial document, and I wasn't able to get it
to do anything but tell me it couldn't open raid0 "Device not
configured", as in

# gpt show ld1
gpt: unable to open device 'rld1d': Device not configured

which, if taken naïvely, is simply false; ld1 works fine for most
things (indeed, at the time I ran the above, I had the machine busily
copying data from ld2 to ld1), so it obviously is configured in.
Either the message is lying or something more complicated is going on.
(Yes, I know I said raid0 and then the example said ld1.  At the time I
ran the example, the disks with raid0 on them were no longer in the

>> There is no /dev/*dk0*, and "MAKEDEV dk0" says dk0 is an "unknown
>> device".
> What MAKEDEV.tmpl version is your /dev/MAKEDEV based on?

# Generated from:
#       NetBSD: MAKEDEV.awk,v 1.15 2004/04/22 23:02:39 enami Exp 
#       NetBSD: MAKEDEV.tmpl,v 2005/07/02 15:49:36 tron Exp 
#       NetBSD: etc.i386/MAKEDEV.conf,v 2005/04/07 11:40:17 tron Exp 

> dk supported as added in 1.59/1.60.  Note that NetBSD 4.0 might not
> have dk enabled by default in GENERIC, I think that was only changed
> after the branch.

I played a bit more with manually-created /dev/*dk0* based on
sys/conf/majors.  I eventually ended up with a repeatable panic when
trying to access the /dev/rdk0a I'd created (c 168 0), so obviously
either dk support is busted in the version I have or I was doing
something fairly badly wrong.

/~\ The ASCII                             Mouse
\ / Ribbon Campaign
 X  Against HTML      
/ \ Email!           7D C8 61 52 5D E7 2D 39  4E F1 31 3E E8 B3 27 4B

Home | Main Index | Thread Index | Old Index