Source-Changes archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Keeping Compatibility - yes please!

I said ...

  | (I've had ifconfig refuse to work, requiring use of a new version
  | for some features, ...

and I was asked "what ifconfig problems?"   I apologies if my message made
it sound as if I was referring to anything recent or important.   My whole
point was that it wasn't important - it also wasn't recent.  As I said
earlier in the same paragraph, NetBSD (that is, the NetBSD developers) has
(have) done a very good job of avoiding compatibility problems.

I no longer recall exactly what ifconfig issue I had, it was a long time
ago now, and (I think) was either a very obscure ioctl, or one that
affected just one specific interface type (perhaps gif or something),
and probably both of those (obscure ioctl and only a problem on one

What I recall most was running ioctl inside a chroot that had the new
binaries installed (while running the new kernel) to perform whavever
operation it was (during the period the system was set up able to go
back to the old kernel, before the userland was upgraded).

I have no complaints about the past - my message was an argument rebutting
(I hope) some proposals for a change of this policy for the future.


Home | Main Index | Thread Index | Old Index