Source-Changes-D archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: CVS commit: src

On Sat, 31 Jul 2010, Izumi Tsutsui wrote:

Log Message:
Make a first pass at documenting the module(9) subsystem.

BTW, I wondered what was the official name of this
when I maintained src/doc/CHANGES...

- src/sys/modules
- options MODULAR
- module(9)

Since all of the public API routines are named module_xxx() I figured that that was the best name for the subsystem.

src/sys/modules/ is where the loadable modules are placed, but the module subsystem lives in src/sys/kern/kern_module*.c

I'll be happy to change it if there's some concensus on what it should be. At this point I was more concerned about recording all the stuff I'd painstakingly gleaned over the past few months, from reading the sources over and over and over again!

| Paul Goyette     | PGP Key fingerprint:     | E-mail addresses:       |
| Customer Service | FA29 0E3B 35AF E8AE 6651 | paul at    |
| Network Engineer | 0786 F758 55DE 53BA 7731 | pgoyette at |
| Kernel Developer |                          | pgoyette at  |

Home | Main Index | Thread Index | Old Index