Port-xen archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Can't boot Xen on -current

D'Arcy Cain wrote:
> I sent this a few days ago but it hasn't shown up yet.  Perhaps my 
> attachment was too big.  I removed it and made it available here 
> instead: http://darcy.vex.net/XenFail.jpg

Looks like PR 50446, "dom0 kernel panics at boot attaching agp", though
I would have expected that to affect both 7_0_1_PATCH and -current.

> I am running Xen 4.6 on both a production NetBSD_7_0_1_PATCH system and 
> -current as of the last day or so.  Everything seems OK on the release 
> kernel but it fails to boot as per the attached screen shot.  The 
> keyboard is dead at that point so pressing a key to view more doesn't 
> work.  I tried Xen 4.6 as well as 4.8.  Same problem.  Here is my 
> boot.cfg line:
> menu=Boot Xen:load /netbsd-XEN3_DOM0.gz console=pc;multiboot /xen.gz 
> dom0_mem=256M dom0_max_vcpus=1 dom0_vcpus_pin
> I saw some messages about disabling apg but does that make sense if you 
> actually have an agp card?  I tried it anyway and it still failed.

Does it fail in the same way, with agpattach() in the backtrace?
Disabling agp works for me, but I don't have an agp card, and I don't
use the onboard video either since the machine has a serial console.
Andreas Gustafsson, gson%gson.org@localhost

Home | Main Index | Thread Index | Old Index