Port-xen archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: xen 4.5.0 packages available

On Wed, Jan 28, 2015 at 5:22 PM, Greg Troxel <gdt%ir.bbn.com@localhost> wrote:

Manuel Bouyer <bouyer%antioche.eu.org@localhost> writes:

> I just tried this, indeed xl hangs. But it you start xencommons,
> xl wakes up. There's no easy way for the kenrel to know if
> xenstored is running, unfortunably.

It seems like a bug if you can't ^C out of it.  (It also seems like a
bug if the xl side of the kernel can't tell there is no active listener
on the xencommons side, but perhaps harder to fix.)

I tried running normal NetBSD kernel, no xen, and ofc not starting xencommons on boot, xl works fine alone and if I try to run `xl list` i get the error:
"libxl: error: libxl.c:109:libxl_ctx_alloc: cannot open libxc handle: No such file or directory
cannot init xl context"

So far seems fine...

But running *with* xen kernel and not starting xencommons, gives me the xl hang (and can't ^C or even kill it :|) , but only if run with arguments... "xl" alone still gives me usage... 

Home | Main Index | Thread Index | Old Index