Port-xen archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: what builds and what doesn't - worse than I expected

On 2014-05-14 04:25, Manuel Bouyer wrote:
On Tue, May 13, 2014 at 07:17:59PM -0700, John Nemeth wrote:
On May 13,  3:58pm, Greg Troxel wrote:
} The HOWTO is out of date, and I wanted to make sure the right thing was
} recommended.   My take is that the right recommendation now is
}    xen: 4.1
}    dom0: NetBSD 6 stable, amd64
} except that maybe it should be 4.2.   I looked at package building

     Unless there is a very good reason to specify otherwise, I
would go with 4.2.  There were a number of positive reports about
it after I imported it.

I'm still using features from the xm toolstack which are not in xl in 4.2 ...

I use xentools42, and both xm and xend are still available. I haven't tried whether it actually works ;-). The only difference is probably having to set xencommons=yes in addition to setting xend=yes in rc.conf. The xendomains rc.d script needs to be adjusted though, because by default it uses xl.

For me xentools42 and the xl toolstack work out of the box, even with vnd based disks. So, +1 to move on to 4.2. I use netbsd 6.1.4.

Home | Main Index | Thread Index | Old Index