Port-xen archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Xen Issues with 4.0

On Sun, Jan 13, 2008 at 05:51:37PM +0900, Curt Sampson wrote:
> Is Xen (both 2 and 3) supposed to be working fine with NetBSD 4.0? I
> seem to be having a great many issues using it as a dom0.

I have Xen3/NetBSD 4.0 dom0 running fine on Dell dual-CPUs poweredge 2850,
and on supermicro dual dual-core CPUs servers.

> On an Asus M2A-VM motherboard with an AMD 64 X2 5600+ CPU, I can bring up
> NetBSD 4.0/i386 as a dom0, but with xen3 the system wedges shortly after
> going multiuser, and with xen2 it wedges when I try to bring up a NetBSD
> domU. This same machine works fine using the Xen 2 live CD with Debian
> as the dom0 and NetBSD 3 domUs. (I've not yet tried a Xen3 live CD.)

This may be an ACPI issue. Did you try disabling acpi ? You need to
do it at both the xen level (acpi=off on the xen.gz line in grub), and
NetBSD kernel (disable acpi after boot -c)

> On an oldish 2.4 GHz Celeron machine that appears to wors fine under
> NetBSD 4.0, Xen3 with NetBSD 4.0 as a dom0 will boot to multiuser, but
> two different ethernet interfaces don't work (an rtk0 keeps giving me
> "timeout" messages that I don't get when not running Xen, and doesn't
> appear to send or receive packets, and an re0 that doesn't appear to
> send or receive packets) and, though the USB interfaces show up in the
> output of usbdevs, no USB devices are ever probed. 

Looks like interrupt issues too. Once again disabling ACPI may help.

Note that on both servers model mentionned above, I run with ACPI
(the supermicro won't run without ACPI because of a BIOS bug).
The only system where I have troubles with ACPI is an old dual-P2
systems. Linux doesn't use APCI on this system either (it seems to
refuse it based on a manufacture date).

Manuel Bouyer <bouyer%antioche.eu.org@localhost>
     NetBSD: 26 ans d'experience feront toujours la difference

Home | Main Index | Thread Index | Old Index