Port-sandpoint archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Problem to load install- kernel on QNAP TS-101

On 11/26/12 10:27, Frank Wille wrote:
On Sun, 25 Nov 2012 18:14:49 +0100
Helge Mühlmeier <H_Muehlmeier%gmx.de@localhost> wrote:

I bought a QNAP TS 101 to run NetBSD on it. It is the V200 board with
the realtek chip...
I have this board working 24h as a server, since more than a year.
IMHO this is one of the best among the supported sandpoint devices.

Here is the output from serial interface:

U-Boot 1.1.2 (Aug 28 2005 - 13:37:25) QNAP System, Inc.
Same firmware revision as mine.

MAC address 00:e0:4c:69:20:01
Hit any key to enter interactive mode: 2^MHit any key to enter
interactive mode: 1^MHit any key to enter interactive mode: 0^M
Does somebody knows what to do now?
Two points:

1. The Realtek-driver in altboot has a known bug, that it always fails
    for the first time after a cold-start. Did you try to load the kernel
    via FTP again, after the firmware had restarted?
    (Yes, I should have documented the bug somewhere...)
You are right... I didn't do that...

2. 1000Mbps connections are untested. I have no idea whether the driver
    can handle them. When it still doesn't work, please try a 100Mbps
    connection (e.g. by using a 100Mbps switch). This worked for me.

This will be tested if booting the install-kernel will work as expected... I will give you a feedback...

I got a "loading netbsd-INSTALL" after a while... But I fails as shown as here:

go 1000000 tftp:netbsd-INSTALL
## Starting application at 0x01000000 ...

NetBSD/sandpoint altboot, revision 1.9
QNAP TS, cpu 265 MHz, bus 132 MHz, 64MB SDRAM
port 0 present
wd0: <HITACHI HTS543225L9SA00> DMA LBA LBA48 238475 MB
wd0: no disklabel
MAC address 00:e0:4c:69:20:01
Hit any key to enter interactive mode: 0
loading "netbsd-INSTALL" read header short
entry=0x4500, ssym=0x3006800, esym=0x10fffc8
NIP: 00004500 XER: 20000000 LR: 01000ED8 REGS: 010ffe90 TRAP: 0700 DAR: 00000000
MSR: 00080030 EE: 0 PR: 0 FP: 0 ME: 0 IR/DR: 11

GPR00: 00004500 010FFF80 FFFFFF1F 03006800 010FFFC8 00000000 00004000 00004500 GPR08: 0000001E 01010000 00000000 03002300 0000014E 04010000 03FF8000 040CE000 GPR16: 598FA088 25120109 0B811844 03F2DC98 00000001 03F2DCA3 01010CA0 01010AFC GPR24: 00000058 01010944 00000001 03F2DDA0 00000000 00000000 03F2DD9C 03F2DCA3
Call backtrace:
Program Check Exception

U-Boot 1.1.2 (Aug 28 2005 - 13:37:25) QNAP System, Inc.

CPU:   MPC8245 Revision 1.4 at 266.666 MHz: 16 kB I-Cache 16 kB D-Cache
Board: Sandpoint 8245 Unity ##Test not implemented yet##
I2C:   ready
DRAM:  64 MB
FLASH: S29GL128N, 16 MB
In:    serial
Out:   serial
Err:   serial
Net:   No ethernet found.
Hit any key to stop autoboot:  0
## Booting image at ff000000 ...
   Image Name:   QNAP Linux-

I have to send altboot.bin via kermit very often and get summaries like this:

SEND-class command failed.
 Packets sent: 17
 Retransmissions: 11
 Timeouts: 1
 Damaged packets: 11
 Fatal Kermit Protocol Error: Too many retries

Hm... Maybe my TTL converter isn't as good as expected? I bought it via ebay.... Cheap stuff from china...

Did you have to send altboot.bin more than two times?


Home | Main Index | Thread Index | Old Index