Port-macppc archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: [PATCH] Incorrect segment 0 initialization for PMAC G5

On 03/31/13 09:21, Phileas Fogg wrote:
> On 03/31/2013 04:22 PM, Nathan Whitehorn wrote:
>> A the author of the FreeBSD code, there are two main hazards with the U4
>> PIC. One is that you have to use big-endian accessors for it, which it
>> seems like you are doing. The other, which I think you have just run
>> into, is that there is a hidden IO APIC attached to the Hypertransport
>> bus that needs to be manually coordinated with the U4 OpenPIC. You can
>> find how this works in the "htpic" driver at the bottom of
>> http://svnweb.freebsd.org/base/head/sys/powerpc/powermac/cpcht.c?revision=230999&view=markup
>> (starts around line 530).
> Thanks for the information. I will take a look at it.
> I have tried FreeBSD 9.1 on my G5 too but getting odd lockups all
> the time, it's quite annoying and unusable currently on my G5.
> I read some posts on the FreeBSD hackers mailing list and
> it seems that i'm not the only one with this problem.
> I tried to manually set FAN speedsa and it didn't help at all.
> I get lockups even when filesystem is checked because of the previous
> lockup. Any idea what is wrong here ? Linux 3.8 runs perfectly
> on the same machine so it cannot be the hardware.
> Regards

Huh. I have no idea -- I'll go back and look at the posts. I have an
11,2 that has been running stably for more than 2 years now, which makes
this hard to debug. It seems like you're getting some pretty deep
knowledge of the hardware now, so I'd appreciate it if you have any
insights. Congratulations on getting your machine booted!

Home | Main Index | Thread Index | Old Index