Port-macppc archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: building userland with a netbooted system


On Thu, 14 Feb 2013, Mouse wrote:
I just setup a diskless system.  I wanted to compile NetBSD 5.1.2
source tree (userland) on it.  It always fails after maybe 12 hours
of compiling.

It'd probably help if you showed us exactly where it fails.  Also, it's
important to know, does it always fail at exactly the same point?

I am pretty sure that it always fails at the same point. Unlimited did nothing to help. I first tried downloading the binaries for 5.1.2 and then with 5.1. I also used different sources each time. It still looks like it stops in the same place.

If you're not sure how to tell, even just making your logfile
(logfiles, if it fails at different points) available for us to fetch
would help.

Does build.sh log somewhere? I can not find it.

I can do:
./build.sh -O ../obj -T ../tools >& ~/build.log &

and then make those logs available.

Just wondering if it is possible to compile userland with a netbooted

I can't see any reason it would be any less possible than on a diskful
machine.  But then, I don't think I've tried to run anything more
recent than 4.x diskless....

I can't see one either, but I haven't tried this since 1.6 or 2.0.

Best Regards,

Home | Main Index | Thread Index | Old Index