Port-macppc archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

-current on PowerBook G4 667 (TiBook)

I finally decided to make a stab at running -current/macppc on one of
my front-line machines.  I have a Titanium PowerBook G4 667MHz (gigabit
ethernet) that is otherwise stuck at MacOS X 10.4.11 (10.5.x refuses to
install on anything with a processor speed less than 867MHz).  Only a
tiny fraction of my desired pkgsrc packages will compile for 10.4.11
anymore, so it's time to get serious about ditching MacOS X in favor of

Some observations:

OpenFirware on this machine has to pass everything in the boot command:

  boot enet:0,ofwboot.xcf enet:/netbsd [opts]

or one thing or another will fail.  I haven't yet examined my dhcpd logs
to see if there were any special identifiers passed.

On boot, the console code sets up the display (radeonfb) on a 1024x768
window (about 85x30 terminal with GALLANT12x22 font) centered in the
1152x768 display.

I'll need to build a kernel with FORCE_FUNCTION_KEYS as no combination
of modifiers would change the brightness/volume control behavior.

I didn't see it listed in the FAQ or other pages, but I discovered
empirically that the key combination "Fn-LCmd" is treated as though the
power switch was pressed.  The kernel emits a message about the power
switch and the machine powers off.  (I didn't try with RCmd, yet.)

X11 works rather well although it only opened a 1024x768 display at the
left end of the screen rather than use the full 1152-pixel width.  I
went back later and looked at ...ATY,StoneParent/ATY,Stone_A and its
width and height properties are 0x00000480 and 0x00000300 (1152x768).
ATY,Stone_B is 640x480.

Fortunately 'twm' and 'fvwm' are navigable with just the left button.
I'll need to look into the xmodmap stuff to simulate other buttons (I
want my middle-button paste!).  At some point, something glitched and
the trackpad lost the X direction, forcing the mouse pointer to the
extreme left on any trackpad event.  The Y direction still worked.
Fortunately, I quickly learned to use fvwm's keyboard navigation.

Although "Fn-<arrow key>" generates the appropriate codes for
Page{Up,Down}/Home/End, the combination with Shift did not allow
scrolling a terminal window (xterm or urxvt).  IIRC, it treated the
keycode as normal input which was delivered to STDIN and echoed on
STDOUT.  More xmodmap stuff?

I worked that way for several hours until a close lightning strike
glitched my ethernet switch.  I rebooted in the course of investigating
the problem, but let the machine come up in MacOS X instead.  I'll
poke at it more next weekend.

|/"\ John D. Baker, KN5UKS               NetBSD     Darwin/MacOS X
|\ / jdbaker[snail]mylinuxisp[flyspeck]com    OpenBSD            FreeBSD
| X  No HTML/proprietary data in email.   BSD just sits there and works!
|/ \ GPGkeyID:  D703 4A7E 479F 63F8 D3F4  BD99 9572 8F23 E4AD 1645

Home | Main Index | Thread Index | Old Index