Port-macppc archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Booting original G3 iMac?

Michael <macallan%netbsd.org@localhost> writes:
> Jarle Greipsland <jarle%uninett.no@localhost> wrote:
> > did anyone find a solution to this problem?  I recently tried to
> > resurrect an old G3 iMac Bondi Blue and dropped in a -current
> > GENERIC kernel, and it exhibited the exact behavior described
> > above, i.e. the last thing printed on the display was a message
> > about "scsibus0: waiting 2 seconds for devices to settle".  And
> > then nothing more.  Any suggestions as to what I should try?
> I think I said this before, but do you have fwohci in your kernel?
> It's known to hang indefinitely on some Apple hardware ( like G3
> PowerBooks, which is why it doesn't attach there ) although it
> used to work on at least 1st generation iMacs and does work
> on G4 hardware. The symptoms would be exactly what you
> describe - the driver hangs while scanning for firewire devices,
> which happens just after that message.
I have tried:
o Booted a -current kernel and entered userconf.  Disabled
  fwohci*, and continued.  It got stuck at the scsibus0:...
  message again.
o Built a custom -current kernel without any traces of fwohci and
  tried to boot it.  Again, it got stuck at the same place.
o Booted the same custom -current kernel, but this time with a
  pre-prepared root-on-NFS setup.  Entered userconf, and disabled
  wdc*.  Now the system booted all the way to multi-user.

In my (fairly un-informed) opinion, there is a problem with the
wdc/atabus/wd-drivers on the old G3 iMacs.  Possibly something to
to with the interrupts, as the system seems to get stuck shortly
after the biomask/netmask/ttymasks are printed.  (why are they
all identical, btw?)

A dmesg of the root-on-NFS setup below.

Any suggestions as to what I should try next?

Copyright (c) 1996, 1997, 1998, 1999, 2000, 2001, 2002, 2003, 2004, 2005,
    2006, 2007, 2008, 2009, 2010, 2011, 2012
    The NetBSD Foundation, Inc.  All rights reserved.
Copyright (c) 1982, 1986, 1989, 1991, 1993
    The Regents of the University of California.  All rights reserved.

NetBSD 6.99.7 (BONDI) #9: Fri Jun  8 11:51:24 CEST 2012
total memory = 98304 KB
avail memory = 89036 KB
timecounter: Timecounters tick every 10.000 msec
userconf: configure system autoconfiguration:
uc> disable wdc*
[  1] wdc* disabled
uc> exit
found heathrow PIC at 80800000
bootpath: /pci/mac-io/ethernet:/netbsd
mainbus0 (root)
cpu0 at mainbus0: 750 (Revision 2.2), ID 0 (primary)
cpu0: HID0 0x8050c0a4<EMCP,NAP,DPM,ICE,DCE,SGE,BTIC,BHT>, powersave: 1
cpu0: 233.33 MHz, no-parity 512KB WB L2 cache (PB SRAM) at 2:1 ratio
grackle0 at mainbus0
pci0 at grackle0 bus 0
pci0: i/o space, memory space enabled
pchb0 at pci0 dev 0 function 0
pchb0: Motorola MPC106 "Grackle" Host Bridge (rev. 0x40)
pchb0: L2 cache: 256K, uniprocessor/none mode
obio0 at pci0 dev 16 function 0: addr 0x80800000
mesh0 at obio0 offset 0x10000 irq 12: 50MHz, SCSI ID 7
scsibus0 at mesh0: 8 targets, 8 luns per target
mesh0: couldn't establish power handler
zsc0 at obio0 irq 15,16
zstty0 at zsc0 channel 0
zstty1 at zsc0 channel 1
davbus at obio0 offset 0x14000 not configured
fdc at obio0 offset 0x15000 not configured
cuda0 at obio0 offset 0x16000 irq 18
nadb0 at cuda0: Apple Desktop Bus
iic at cuda0 not configured
ide at obio0 offset 0x20000 not configured
ide at obio0 offset 0x21000 not configured
bm0 at obio0 offset 0x11000 irq 42,33: address 00:05:02:e3:6f:f9
lxtphy0 at bm0 phy 0: LXT970 10/100 media interface, rev. 1
lxtphy0: 10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, auto
nvram0 at obio0 offset 0x60000
machfb0 at pci0 dev 18 function 0: ATI Technologies 3D Rage IIC (rev. 0x3a)
machfb0: aperture size 01000000
machfb0: 16 MB aperture at 0x81000000, 4 KB registers at 0x80881000
machfb0: 128 KB ROM at 0x00000000
max_dotclock according to supported modes: 78750
CLOCK_CNTL: 001f0a00
using clock 0
ref_div: 31
mclk_fb_div: 181
machfb0: 6144 KB SGRAM 83.598 MHz, maximum RAMDAC clock 230 MHz
machfb0: initial resolution 1024x768 at 8 bpp
wsdisplay0 at machfb0 kbdmux 1: console (default, vt100 emulation)
wsmux1: connecting to wsdisplay0
direct rendering for machfb0 unsupported
ohci0 at pci0 dev 20 function 0: Opti 82C861 (rev. 0x10)
ohci0: interrupting at irq 28
ohci0: OHCI version 1.0, legacy support
usb0 at ohci0: USB revision 1.0
biomask 1f000000 netmask 1f000000 ttymask 1f000000
timecounter: Timecounter "clockinterrupt" frequency 100 Hz quality 0
timecounter: Timecounter "mftb" frequency 16666666 Hz quality 100
scsibus0: waiting 2 seconds for devices to settle...
uhub0 at usb0: Opti OHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub0: 2 ports with 2 removable, self powered
uhub1 at uhub0 port 1: NEC hub, class 9/0, rev 1.00/1.00, addr 2
uhub1: 4 ports with 4 removable, self powered
uhidev0 at uhub1 port 1 configuration 1 interface 0
uhidev0: Alps Electric M2452, rev 1.00/1.01, addr 3, iclass 3/1
ukbd0 at uhidev0
wskbd0 at ukbd0: console keyboard, using wsdisplay0
uhidev1 at uhub1 port 2 configuration 1 interface 0
uhidev1: Logitech M4848, rev 1.00/5.00, addr 4, iclass 3/1
ums0 at uhidev1: 1 button
wsmouse0 at ums0 mux 0
swwdog0: software watchdog initialized
boot device: bm0
root on bm0
nfs_boot: trying DHCP/BOOTP
nfs_boot: DHCP next-server:
nfs_boot: my_name=bondi
nfs_boot: my_domain=local
nfs_boot: my_addr=
nfs_boot: my_mask=
nfs_boot: gateway=
root on
root file system type: nfs

Home | Main Index | Thread Index | Old Index