Port-evbmips archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

ssh-keygen not working with MERAKI kernel

Hi there!

This may be the wrong place to ask this question, but I'll start here just in 

I've got a cross-compiled setup now and can boot my fonera into netbsd with nfs 
root.  There's a few issues, like lack of ipv6 support, that I need to add to 
the kernel, but besides that it is more or less stable and in multiuser mode.

My problem is that ssh-keygen is not generating the ssh keys so that I can log 
in through the network.  Each time, the program reports that the generation has 
failed.  Here's the output from trying to start sshd and having it generate the 

fonera# /etc/rc.d/sshd start
[: -d: unexpected operator
Generating public/private rsa1 key pair.
rsa_generate_private_key: key generation failed.
Generating public/private dsa key pair.
dsa_generate_private_key: DSA_generate_key failed.
Generating public/private rsa key pair.
rsa_generate_private_key: key generation failed.

Just running ssh-keygen returns almost immediately with the same error.

Any ideas why this might be happening?  The last time I compiled netbsd-current 
with i386, it all worked fine.


Home | Main Index | Thread Index | Old Index