Port-evbmips archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: ssh-keygen not working with MERAKI kernel


> Just running ssh-keygen returns almost immediately with the same
> error.
> Any ideas why this might be happening?  The last time I compiled
> netbsd-current with i386, it all worked fine.

I ran in exactly the same problem with my Edimax BR6104K. The reason is
pretty simple: The device major and minors are slightly different from
i386. This especially affects /dev/random. Just recreate it with
./MAKEDEV random in /dev or replace it manually. Correct is:

br6104k2 ~ # ls -lisa /dev/random
4530143 0 cr--r--r--  1 root  wheel  39, 0 Jan 14 23:13 /dev/random

I guess yours is different... change it and ssh will run. I got the same
problem with some ptys so ./MAKDEV all is the solve-all solution.



  / Dr. Jan Richling - http://www.richling.de                      /
 / Member of Computer Architecture and Communication Group -      /
/ Department of Computer Science - Humboldt University Berlin    /

Home | Main Index | Thread Index | Old Index