Port-cobalt archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Qube2 Install woes AND USB/FW400 support?


I have never tried to install with the install cd or at least I was never
successful. However, it sounds like you might already have NetBSD
installed a cobalt. If this is the case, why not just update your install?
This would be faster and easier.


On Sun, 4 May 2008, Mark wrote:

> Date: Sun, 4 May 2008 23:32:23 +0100
> From: Mark <md.benson%gmail.com@localhost>
> To: Cobalt MIPS NetBSD <port-cobalt%netbsd.org@localhost>
> Subject: Qube2 Install woes AND USB/FW400 support?
> Hi,
>       I have a Qube 2 (Gateway Microserver) that I am trying to install
> NetBSD-cobalt to but I have a problem. My i386 machine is a Sun Java
> Workstation, and it has on-board FireWire. The restore CD I have
> downloaded (a 4.0 Final CD ISO recently posted on this list) is
> picking the FW400 port (fwip0) and assigning it as the designated
> network device for networking ahead of the Broadcom GigaBit Ethernet
> port (bge0). This, obviously, is breaking the install as it's not
> communicating with the bge0 ethernet device.
> At least that's what I assume is wrong, I could be way off.
> Can I disable the fwip0 and enable the bge0 device and then try the
> bootstrap from there? It should be fairly straightforward but I'm a
> bit stuck. I tried fooling about with ifconfig alterations once the CD
> had booted but it wouldn't play ball. This ought to be pretty easy to
> get around in theory... right?
> I haven't got the facilities to build my own bootstrap restore CD. I
> just want to download a NetBSD restore CD and get it running with
> something more recent than 3.99.17. I've already categorically failed
> at installing Debian and I'm not willing to plough more time into
> futzing about than I have to.
> ------
> Secondly. If, when, maybe, I get it working I'd like to use external
> drives with it, the single internal 80GB is ok for now but it'll need
> expanding at some stage. I figure either FireWire or USB PCI cards
> ought to work, but the support wasn't compiled into 3.99.17. Hopefully
> if I can start afresh with 4.0 I can recompile a kernel with support
> for these cards built in? Is that possible?
> Thanks for any help...
> --
> Mark Benson
> My Blog:
> <http://markbenson.org/blog>
> Visit my Homepage: <http://homepage.mac.com/markbenson>
> "Never send a human to do a machine's job..."

Home | Main Index | Thread Index | Old Index