Port-atari archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Need help getting started

Hi again,

i can now install the NetBSD system almost to my needs, but it fails
to boot .

During install (via ftp) i see that only /binary/sets/kern-ATARITT.tgz is fetched.
shouldn't i see kern-FALCON.tgz downloaded?

How do i change the kernel after the installation finished?
I can boot the new system just like before, with "loadbsd.ttp -b netbsd"
and then pointing to my harddisk wd1a, i guess?

And then i need to install nano for having an editor i can work with
(vi isn't mine)...


Am 11.03.2014 07:10, schrieb Stefan Niestegge:
Okay, i got the installer started and did a default quickinstall to the
CF card. My HD is partitioned using HD Driver, which seems to do
extended partitions different than AHDI.


Am 10.03.2014 07:05, schrieb Stefan Niestegge:
Thanks for the reply, Alex

Am 10.03.2014 00:20, schrieb Alexander Bochmann:
...on Sun, Mar 09, 2014 at 10:44:47PM +0100, Stefan Niestegge wrote:

  > > There are six atari floppy images to be found in the
  > >     atari/installation/floppies subdirectory of the NetBSD 6.1.2
  > >     tion.
  > This directory does not exist any more. I guess the directory
  > atari/installation/miniroot contains what i need.

It's been quite some time since I installed NetBSD from scratch on my
Atari TT the last time, but I don't remember using installation disks...

I think I had a harddisk prepared with three partitions, one small
to hold the tools and installation sets, one for NetBSD, and another
one for swap. Even though I have enough RAM, I used the file2swp method
to copy sysinst.fs to the swap partition - in the install docs, that
starts from:

...and then using the swap partition with sysinst.fs as root device.

I am going to try this, then.

  > When i boot the kernel, it ask me for root device. I tried md0a
and fd0a
  > but nothing worked.

That should work too - although from the docs, with the 1.44MB sysinst
you'll have to use "md2a" - guess there is some magic to automatically
load the
installer floppy image into a matching RAM disk depending on the
device name?

I get a floppydrive timeout or a recalibration error displayed.
i read in the mailinglist that the md2a approach is broken, and fd0a
should be used instead. There was a patch suggested, too

Did the kernel say anything about detecting your floppy drive? You
should be
fine then... On the TT it's something like:

  > fdc0 at mainbus0
  > fd0 at fdc0: 1.44MB 80 cyl, 2 head, 18 sec

(That's copied from an old dmesg, but I don't think the message has
changed much.)

Yes, i get these info, too.

Thanks so far,

Home | Main Index | Thread Index | Old Index