Port-atari archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Need help getting started

...on Sun, Mar 09, 2014 at 10:44:47PM +0100, Stefan Niestegge wrote:

 > > There are six atari floppy images to be found in the
 > >     atari/installation/floppies subdirectory of the NetBSD 6.1.2 distribu-
 > >     tion.
 > This directory does not exist any more. I guess the directory
 > atari/installation/miniroot contains what i need.

It's been quite some time since I installed NetBSD from scratch on my  
Atari TT the last time, but I don't remember using installation disks...

I think I had a harddisk prepared with three partitions, one small GEMDOS 
to hold the tools and installation sets, one for NetBSD, and another smaller 
one for swap. Even though I have enough RAM, I used the file2swp method 
to copy sysinst.fs to the swap partition - in the install docs, that part 
starts from:

...and then using the swap partition with sysinst.fs as root device.

 > When i boot the kernel, it ask me for root device. I tried md0a and fd0a
 > but nothing worked.

That should work too - although from the docs, with the 1.44MB sysinst image, 
you'll have to use "md2a" - guess there is some magic to automatically load the 
installer floppy image into a matching RAM disk depending on the device name?

Did the kernel say anything about detecting your floppy drive? You should be 
fine then... On the TT it's something like:

 > fdc0 at mainbus0
 > fd0 at fdc0: 1.44MB 80 cyl, 2 head, 18 sec

(That's copied from an old dmesg, but I don't think the message has changed 

 > The kernel also asks for dump device and filesystem -  the
 > installation notes say nothing about it. Are the defaults safe to
 > use?



Home | Main Index | Thread Index | Old Index