Port-arm archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: 64-bit pi 3 grief

On Mon, 2 Nov 2020 at 13:52, John Klos <john%ziaspace.com@localhost> wrote:
> > Still, have to ask, has anyone cross compiled 64-bit netbsd arm, using
> > 64-bit netbsd arm with 1GB of ram?

> If it's 64 bit NetBSD ARM compiling 64 bit NetBSD ARM, then it's not cross
> compiled.

I'm using build.sh with -m so it builds and uses a cross compiler.
Which, to split hairs, is different to using the native tools.
However, the effective and the load are pretty much the same.

> I've natively run an aarch64 build on a Pi many times.


> > Now I hit two problems:
> > #1: the kernel doesn't wait for the sd0 to come online and instead
> > prompts for the root device (I hit this long ago on an odroid, and the
> > SSD was a workaround ...)
> Add this to config.txt on your MS-DOS partition on the SD card:
> # Waits a while so spinning rust disk has time to spin up
> boot_delay=10

Tried it, but as Paul M points out, it doesn't help.  The USB
controller needs two thumbs up before the disk starts spinning, for
SSDr that's instant.

I'll try John K's suggestion and try to update the firmware.

> > #2: the prompt displays "root device: ld0", I think it should have
> > displayed "root device: sd0a" since that is what was specified
> > Should "init" have waited longer for "sd0a" before prompting for the
> > root device (perhaps it waited for ld0?).  Since "sd0" does come
> > online while "init" is sitting at the "root device" prompt, should
> > "init" be able to detect this?
> > Any workarounds?  I"m building a custom kernel with "root on sd0" to
> > see if it helps.
> NetBSD-current uses boot.cfg on the MS-DOS partition on the SD card, which
> would look like this:
> menu=Boot normally:rndseed /var/db/entropy-file;boot netbsd root=/dev/sd0a
> menu=Boot single user:rndseed /var/db/entropy-file;boot netbsd root=/dev/sd0a -s
> menu=Drop to boot prompt:prompt
> default=1
> timeout=8
> NetBSD-9, though, can have an alternate root by changing this line in
> cmdline.txt on the MS-DOS partition on the SD card like so:
> root=sd0a console=fb

Yes, as in:

> > - root=sd0a console=fb

> > setup #3:
> > - Pi3 with latest 9 GENERIC64 kernel on SD card; cross compiled from linux
> > - root=sd0a console=fb
> > - wired ethernet
> > but:
> > - usb keyboard (either from power-up, or plugged in after the "root
> > device" prompt)
> > - sd0a is a usb/*spinning-disk* (configured kernel boot param)
> > Kaboom.  Based on the HIDs and USBs in the backtrace, and page upon
> > page of what look like usb message dumps, I'm guessing its the kernel
> > trying to read the keyboard.
> Can you send a picture of this?


It starts at the root device prompt, reports sd0 as it comes online,
seems to do nothing while I find a keyboard cable to plug in (I've
tried 3, they all panic).  and then (unreadably) starts to panic.  At
the very end the bt is readable.

I guess I need a better capture device.


Home | Main Index | Thread Index | Old Index